#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^([MF]\/\d{2})\/ (?#Gender/Age, required.)" & @CRLF & _
"" & @CRLF & _
"( (?#Height, required.)" & @CRLF & _
" (?:\d{1}[\'\’]? (?#Optional \'\’ unit markings.)" & @CRLF & _
" (?: (?#Groups starting with ?: are non-capturing.)" & @CRLF & _
" (?:" & @CRLF & _
" [02-9]|1[01]?" & @CRLF & _
" )(?:[\"”]|\'\')? (?#Optional "\'\' unit markings.)" & @CRLF & _
" )?" & @CRLF & _
" )|" & @CRLF & _
" \d{1,3}cm|" & @CRLF & _
" [12]m(?:\d{1,2}(?:cm)?)? (?#Optional cm unit marking.)" & @CRLF & _
")\ ?" & @CRLF & _
"" & @CRLF & _
" (?#Weight before to after, required. ?P<weight> is a named capturing group, associated with match sub-pattern ?P=weight. It forces the user to be consistent, either using only lbs, or only kg for the entire match, also used in Lifting Stats section.)" & @CRLF & _
"\[(\d{2,3}\ ?(?P<weight>lbs|kg)\ to\ \d{2,3}\ ?(?P=weight))\]\ ? (?# Optional space before lbs|kg. *Changed to require space before and after "to".)" & @CRLF & _
"" & @CRLF & _
"\( (?#Time Period, required)" & @CRLF & _
" (" & @CRLF & _
" (?:\d{1,2}\ ?years?)| (?#Optional space before years, optional s in years.)" & @CRLF & _
" (?:" & @CRLF & _
" (?:[2-9]|1[01]?)\ ?(?:month|week)s? (?#Optional space before months|weeks, optional s at end.)" & @CRLF & _
" )|" & @CRLF & _
" (?:\d{1,2}\ ?years?[;,]?\ ? (?#Optional space before years, optional s in years. Optional space after.)" & @CRLF & _
" (?:[02-9]|1[01]?)\ ?months?)| (?#Optional space before monthss, optional s in months.)" & @CRLF & _
" )" & @CRLF & _
"\)\ ?" & @CRLF & _
"" & @CRLF & _
"(?:\ ?\+\ ?\( (?#Lifting Stats, optional. Optional space before/after + .)" & @CRLF & _
" ((?:[DSBO]:\ ?(?:\d{2,3})\ ?(?P=weight)(?:[;,]\ ?)?){1,4}) (?# Optional space after [DSBO]: . Optional space before lbs|kg. Optional space after ;, delimiter. Changed from 4 repeated statements to one recursive group.)" & @CRLF & _
"\)(?<=[sg]\)))? (?# ?<= is a Positive Lookbehind. It requires the ; or , delimiter between stats, but prevents the delimiter after the last stat.)" & @CRLF & _
"" & @CRLF & _
"(\ .*)? (?#Comments, optional. *Changed: Required space before comments section.)" & @CRLF & _
"$|^\[Meta\].*"
Local $sString = "M/24/5'10" [175lbs to 150lbs] (1 year)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")