import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([MF]\\/\\d{2})\\/ (?#Gender/Age, required.)\n\n"
+ "( (?#Height, required.)\n"
+ " (?:\\d{1}[\\'\\’]? (?#Optional \\'\\’ unit markings.)\n"
+ " (?: (?#Groups starting with ?: are non-capturing.)\n"
+ " (?:\n"
+ " [02-9]|1[01]?\n"
+ " )(?:[\\\"”]|\\'\\')? (?#Optional \"\\'\\' unit markings.)\n"
+ " )?\n"
+ " )|\n"
+ " \\d{1,3}cm|\n"
+ " [12]m(?:\\d{1,2}(?:cm)?)? (?#Optional cm unit marking.)\n"
+ ")\\ ?\n\n"
+ " (?#Weight before to after, required. ?P<weight> is a named capturing group, associated with match sub-pattern ?P=weight. It forces the user to be consistent, either using only lbs, or only kg for the entire match, also used in Lifting Stats section.)\n"
+ "\\[(\\d{2,3}\\ ?(?P<weight>lbs|kg)\\ to\\ \\d{2,3}\\ ?(?P=weight))\\]\\ ? (?# Optional space before lbs|kg. *Changed to require space before and after \"to\".)\n\n"
+ "\\( (?#Time Period, required)\n"
+ " (\n"
+ " (?:\\d{1,2}\\ ?years?)| (?#Optional space before years, optional s in years.)\n"
+ " (?:\n"
+ " (?:[2-9]|1[01]?)\\ ?(?:month|week)s? (?#Optional space before months|weeks, optional s at end.)\n"
+ " )|\n"
+ " (?:\\d{1,2}\\ ?years?[;,]?\\ ? (?#Optional space before years, optional s in years. Optional space after.)\n"
+ " (?:[02-9]|1[01]?)\\ ?months?)| (?#Optional space before monthss, optional s in months.)\n"
+ " )\n"
+ "\\)\\ ?\n\n"
+ "(?:\\ ?\\+\\ ?\\( (?#Lifting Stats, optional. Optional space before/after + .)\n"
+ " ((?:[DSBO]:\\ ?(?:\\d{2,3})\\ ?(?P=weight)(?:[;,]\\ ?)?){1,4}) (?# Optional space after [DSBO]: . Optional space before lbs|kg. Optional space after ;, delimiter. Changed from 4 repeated statements to one recursive group.)\n"
+ "\\)(?<=[sg]\\)))? (?# ?<= is a Positive Lookbehind. It requires the ; or , delimiter between stats, but prevents the delimiter after the last stat.)\n\n"
+ "(\\ .*)? (?#Comments, optional. *Changed: Required space before comments section.)\n"
+ "$|^\\[Meta\\].*";
final String string = "M/24/5'10\" [175lbs to 150lbs] (1 year)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}