using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([MF]\/\d{2})\/ (?#Gender/Age, required.)
( (?#Height, required.)
(?:\d{1}[\'\’]? (?#Optional \'\’ unit markings.)
(?: (?#Groups starting with ?: are non-capturing.)
(?:
[02-9]|1[01]?
)(?:[\""”]|\'\')? (?#Optional ""\'\' unit markings.)
)?
)|
\d{1,3}cm|
[12]m(?:\d{1,2}(?:cm)?)? (?#Optional cm unit marking.)
)\ ?
(?#Weight before to after, required. ?P<weight> is a named capturing group, associated with match sub-pattern ?P=weight. It forces the user to be consistent, either using only lbs, or only kg for the entire match, also used in Lifting Stats section.)
\[(\d{2,3}\ ?(?P<weight>lbs|kg)\ to\ \d{2,3}\ ?(?P=weight))\]\ ? (?# Optional space before lbs|kg. *Changed to require space before and after ""to"".)
\( (?#Time Period, required)
(
(?:\d{1,2}\ ?years?)| (?#Optional space before years, optional s in years.)
(?:
(?:[2-9]|1[01]?)\ ?(?:month|week)s? (?#Optional space before months|weeks, optional s at end.)
)|
(?:\d{1,2}\ ?years?[;,]?\ ? (?#Optional space before years, optional s in years. Optional space after.)
(?:[02-9]|1[01]?)\ ?months?)| (?#Optional space before monthss, optional s in months.)
)
\)\ ?
(?:\ ?\+\ ?\( (?#Lifting Stats, optional. Optional space before/after + .)
((?:[DSBO]:\ ?(?:\d{2,3})\ ?(?P=weight)(?:[;,]\ ?)?){1,4}) (?# Optional space after [DSBO]: . Optional space before lbs|kg. Optional space after ;, delimiter. Changed from 4 repeated statements to one recursive group.)
\)(?<=[sg]\)))? (?# ?<= is a Positive Lookbehind. It requires the ; or , delimiter between stats, but prevents the delimiter after the last stat.)
(\ .*)? (?#Comments, optional. *Changed: Required space before comments section.)
$|^\[Meta\].*";
string input = @"M/24/5'10"" [175lbs to 150lbs] (1 year)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}