using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[(?<type>.*)\]\[(?<ticket>.*)\] (?<scope>.*): (?<message>.*$)";
string input = @"[TYPE][JIRA-123] Scope: Message";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}