$re = '/^\[(?<type>.*)\]\[(?<ticket>.*)\] (?<scope>.*): (?<message>.*$)/m';
$str = '[TYPE][JIRA-123] Scope: Message';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);