re = /^\[(?<type>.*)\]\[(?<ticket>.*)\] (?<scope>.*): (?<message>.*$)/m
str = '[TYPE][JIRA-123] Scope: Message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end