#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((.*[0-9]+)[a-zA-Z]+.*)|((.*[a-zA-Z]+)[0-9]+.*)$"
Local $sString = "hkjsfhkjsdfh8098" & @CRLF & _
"kjhskjf" & @CRLF & _
"98798gkhkj" & @CRLF & _
"a1b4cc" & @CRLF & _
"abc" & @CRLF & _
"123" & @CRLF & _
"abc d77hv" & @CRLF & _
"798 h7ghd" & @CRLF & _
"798 abcd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")