import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((.*[0-9]+)[a-zA-Z]+.*)|((.*[a-zA-Z]+)[0-9]+.*)$";
final String string = "hkjsfhkjsdfh8098\n"
+ "kjhskjf\n"
+ "98798gkhkj\n"
+ "a1b4cc\n"
+ "abc\n"
+ "123\n"
+ "abc d77hv\n"
+ "798 h7ghd\n"
+ "798 abcd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}