$re = '/^((.*[0-9]+)[a-zA-Z]+.*)|((.*[a-zA-Z]+)[0-9]+.*)$/m';
$str = 'hkjsfhkjsdfh8098
kjhskjf
98798gkhkj
a1b4cc
abc
123
abc d77hv
798 h7ghd
798 abcd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);