using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(.*?\).*?:.*?<br>(?=\(|$)";
string input = @"( 5m 3s ) John: Hi <br> Hello <br>( 6m 2s ) Jane: Hello<br>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}