$re = '/\(.*?\).*?:.*?<br>(?=\(|$)/';
$str = '( 5m 3s ) John: Hi <br> Hello <br>( 6m 2s ) Jane: Hello<br>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);