re = /\(.*?\).*?:.*?<br>(?=\(|$)/
str = '( 5m 3s ) John: Hi <br> Hello <br>( 6m 2s ) Jane: Hello<br>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end