package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<DAY>\d?\d)(?<SEPARATOR>[-.\/])(?<MONTH>\d\d)(\k<SEPARATOR>)(?<YEAR>\d{4})`)
var str = `13-07-2020
8.07.2020
13/07/2020
13/07-2020`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}