re = /(?<DAY>\d?\d)(?<SEPARATOR>[-.\/])(?<MONTH>\d\d)(\k<SEPARATOR>)(?<YEAR>\d{4})/m
str = '13-07-2020
8.07.2020
13/07/2020
13/07-2020'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end