import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<DAY>\\d?\\d)(?<SEPARATOR>[-.\\/])(?<MONTH>\\d\\d)(\\k<SEPARATOR>)(?<YEAR>\\d{4})";
final String string = "13-07-2020\n"
+ "8.07.2020\n"
+ "13/07/2020\n\n"
+ "13/07-2020";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}