#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^/\n]*(?:/(?!/)[^/\n]*)*foo.*)"
Local $sString = "Not to be found:" & @CRLF & _
" // foo " & @CRLF & _
" // foobar" & @CRLF & _
" // foo " & @CRLF & _
" // foobar" & @CRLF & _
" // // foobar" & @CRLF & _
" bar // foobar" & @CRLF & _
"To be found:" & @CRLF & _
" foo " & @CRLF & _
" / foobar" & @CRLF & _
" bar foo " & @CRLF & _
" foobar"
Local $sSubst = "//\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)