using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^/\n]*(?:/(?!/)[^/\n]*)*foo.*)";
string substitution = @"//\1";
string input = @"Not to be found:
// foo
// foobar
// foo
// foobar
// // foobar
bar // foobar
To be found:
foo
/ foobar
bar foo
foobar";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}