$re = '~^([^/\n]*(?:/(?!/)[^/\n]*)*foo.*)~m';
$str = 'Not to be found:
// foo
// foobar
// foo
// foobar
// // foobar
bar // foobar
To be found:
foo
/ foobar
bar foo
foobar';
$subst = "//\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;