using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!<p class=""test_formal"">).)*<span class=""test_formal2"">.*$";
string input = @"<p class=""test_formal"">
<span class=""test_formal2"">
<p class=""test_formal""><span class=""test_formal2"">
blah <p class=""test_formal""><span class=""test_formal2""> blah blah
<span class=""test_formal2""><p class=""test_formal"">
blah blah <span class=""test_formal2""><p class=""test_formal""> blah blah
--------Toto-----
THIS SHOULD NOT BE SELECTED <p class=""test_formal""><em>Bla Bla</em></p>
because don't have `<span class=""test_formal2"">`
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}