use strict;
my $str = '<p class="test_formal">
<span class="test_formal2">
<p class="test_formal"><span class="test_formal2">
blah <p class="test_formal"><span class="test_formal2"> blah blah
<span class="test_formal2"><p class="test_formal">
blah blah <span class="test_formal2"><p class="test_formal"> blah blah
--------Toto-----
THIS SHOULD NOT BE SELECTED <p class="test_formal"><em>Bla Bla</em></p>
because don\'t have `<span class="test_formal2">`
';
my $regex = qr/^(?:(?!<p class="test_formal">).)*<span class="test_formal2">.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}