const regex = /(?:
^
(?<host>[\w-]+\.[\w-.]*?)
\.\s*
(?<ttl>\d+)
\s*
(?<wtf>\w*)
\s*
(?<rectype>\w*)
\s*
(?<value>.*)
\s*$
)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:
^
(?<host>[\\w-]+\\.[\\w-.]*?)
\\.\\s*
(?<ttl>\\d+)
\\s*
(?<wtf>\\w*)
\\s*
(?<rectype>\\w*)
\\s*
(?<value>.*)
\\s*$
)', 'gm')
const str = `agamerica-qa.commloanservices.com.
====================================
agamerica-qa.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792585 1200 180 1209600 600
agamerica-qa.commloanservices.com. 86400 IN NS dns002.pnc.com.
agamerica-qa.commloanservices.com. 86400 IN NS dns001.pnc.com.
agamerica-qa.commloanservices.com. 86400 IN NS dns000.pnc.com.
bin.agamerica-qa.commloanservices.com. 30 IN CNAME gf0.agamerica-qa.commloanservices.com.
gf0.agamerica-qa.commloanservices.com. 3600 IN A 161.150.124.249
agamerica-qa.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792585 1200 180 1209600 600
agamerica.commloanservices.com.
====================================
agamerica.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792587 1200 180 1209600 600
agamerica.commloanservices.com. 86400 IN NS dns002.pnc.com.
agamerica.commloanservices.com. 86400 IN NS dns001.pnc.com.
agamerica.commloanservices.com. 86400 IN NS dns000.pnc.com.
agamerica.commloanservices.com. 3600 IN A 161.150.133.216
bin.agamerica.commloanservices.com. 30 IN CNAME gf2.agamerica.commloanservices.com.
gf1.agamerica.commloanservices.com. 3600 IN A 161.150.116.249
gf2.agamerica.commloanservices.com. 3600 IN A 161.150.40.249
agamerica.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792587 1200 180 1209600 600`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}