# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:
^
(?<host>[\w-]+\.[\w-.]*?)
\.\s*
(?<ttl>\d+)
\s*
(?<wtf>\w*)
\s*
(?<rectype>\w*)
\s*
(?<value>.*)
\s*$
)
"""
test_str = ("agamerica-qa.commloanservices.com.\n"
"====================================\n"
"agamerica-qa.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792585 1200 180 1209600 600\n"
"agamerica-qa.commloanservices.com. 86400 IN NS dns002.pnc.com.\n"
"agamerica-qa.commloanservices.com. 86400 IN NS dns001.pnc.com.\n"
"agamerica-qa.commloanservices.com. 86400 IN NS dns000.pnc.com.\n"
"bin.agamerica-qa.commloanservices.com. 30 IN CNAME gf0.agamerica-qa.commloanservices.com.\n"
"gf0.agamerica-qa.commloanservices.com. 3600 IN A 161.150.124.249\n"
"agamerica-qa.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792585 1200 180 1209600 600\n\n\n"
"agamerica.commloanservices.com.\n"
"====================================\n"
"agamerica.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792587 1200 180 1209600 600\n"
"agamerica.commloanservices.com. 86400 IN NS dns002.pnc.com.\n"
"agamerica.commloanservices.com. 86400 IN NS dns001.pnc.com.\n"
"agamerica.commloanservices.com. 86400 IN NS dns000.pnc.com.\n"
"agamerica.commloanservices.com. 3600 IN A 161.150.133.216\n"
"bin.agamerica.commloanservices.com. 30 IN CNAME gf2.agamerica.commloanservices.com.\n"
"gf1.agamerica.commloanservices.com. 3600 IN A 161.150.116.249\n"
"gf2.agamerica.commloanservices.com. 3600 IN A 161.150.40.249\n"
"agamerica.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792587 1200 180 1209600 600")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.