using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([thw]):([a-z09]+)+?;";
string input = @"t:foo;h:foo;w:foo;
t:foo;w:foo;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}