package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([thw]):([a-z09]+)+?;`)
var str = `t:foo;h:foo;w:foo;
t:foo;w:foo;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}