$re = '/([thw]):([a-z09]+)+?;/';
$str = 't:foo;h:foo;w:foo;
t:foo;w:foo;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);