$re = '~.*\.php$(*SKIP)(*FAIL)|^/(alfa|beta)((/wp-(content|admin|includes))([^?\s]*)).*~m';
$str = '/alfa/wp-includes/js/jquery/jquery.js
/beta/wp-content/plugins/app/js/media.js?parameter=value
/beta/wp-admin/network
/beta/wp-content/themes/journal/data.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);