re = /.*\.php$(*SKIP)(*FAIL)|^\/(alfa|beta)((\/wp-(content|admin|includes))([^?\s]*)).*/m
str = '/alfa/wp-includes/js/jquery/jquery.js
/beta/wp-content/plugins/app/js/media.js?parameter=value
/beta/wp-admin/network
/beta/wp-content/themes/journal/data.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end