import re
regex = re.compile(r".*\.php$(*SKIP)(*FAIL)|^/(alfa|beta)((/wp-(content|admin|includes))([^?\s]*)).*", flags=re.MULTILINE)
test_str = ("/alfa/wp-includes/js/jquery/jquery.js\n"
"/beta/wp-content/plugins/app/js/media.js?parameter=value\n"
"/beta/wp-admin/network\n"
"/beta/wp-content/themes/journal/data.php")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")