using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(\?example=.+?)(\?.*)";
string input = @"http://ikmultimedia.com
http://www.ikmultimedia.com
http://somethingelse.net?example=50?whatever=false
http://www.test.com?firstquery=dog?example=cat
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}