import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(\\?example=.+?)(\\?.*)";
final String string = "http://ikmultimedia.com\n"
+ "http://www.ikmultimedia.com\n"
+ "http://somethingelse.net?example=50?whatever=false\n"
+ "http://www.test.com?firstquery=dog?example=cat\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}