re = /.*(\?example=.+?)(\?.*)/m
str = 'http://ikmultimedia.com
http://www.ikmultimedia.com
http://somethingelse.net?example=50?whatever=false
http://www.test.com?firstquery=dog?example=cat
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end