package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<my_field>[^_]*_[^_]*)_.*`)
var str = `DR300_Corp_76
BELLOE_MX400_32
AB200_Corp_123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}