$re = '/(?<my_field>[^_]*_[^_]*)_.*/m';
$str = 'DR300_Corp_76
BELLOE_MX400_32
AB200_Corp_123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);