// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<my_field>[^_]*_[^_]*)_.*").unwrap();
let string = "DR300_Corp_76
BELLOE_MX400_32
AB200_Corp_123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}