package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[2-9]|\d\d\d*)$`)
var str = `1
2
3
4
5
10
100
1000
10000
111111
123
234
1234
12345
111111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}