import re
regex = re.compile(r"^(?:[2-9]|\d\d\d*)$", flags=re.MULTILINE)
test_str = ("1\n"
"2\n"
"3\n"
"4\n"
"5\n"
"10\n"
"100\n"
"1000\n"
"10000\n"
"111111\n"
"123\n"
"234\n"
"1234\n"
"12345\n"
"111111")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")