package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s+)#+|^#`)
var str = `#quick ##brown f#x`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}