const regex = /(\s+)#+|^#/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s+)#+|^#', 'g')
const str = `#quick ##brown f#x`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);