use strict;
my $str = '#quick ##brown f#x';
my $regex = qr/(\s+)#+|^#/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";