use strict;
my $str = '#سلام@چطوری!خوبی؟چه&خبرا*چیکارا+میکنی=کجاها^میری><?~$%÷×';
my $regex = qr/[`~!@#$%^&*()_|+\-=?؟;:'"÷,.×<>\{\}\[\]\\\/]+/mp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";