$re = '/[`~!@#$%^&*()_|+\-=?؟;:\'"÷,.×<>\{\}\[\]\\\\\/]+/m';
$str = '#سلام@چطوری!خوبی؟چه&خبرا*چیکارا+میکنی=کجاها^میری><?~$%÷×';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;