import Foundation
let pattern = ##"[`~!@#$%^&*()_|+\-=?؟;:'"÷,.×<>\{\}\[\]\\\/]+"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"#سلام@چطوری!خوبی؟چه&خبرا*چیکارا+میکنی=کجاها^میری><?~$%÷×"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)