using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"frame[_]*(?P<fidx>\d{5,6})[_ .]|(?P<device_id>[0-9a-z]{16})_(?P<date>\d{8})_(?P<time>\d{6})_(?P<microseconds>\d{6})_(?P<frame_index>\d{6})";
string input = @"/orcam/field_recordings/myear/recordings/2019/06/190611_141138_Unoaa_LOrcam_Cvoice_recording_check_911_up_V9_2_2_ear_en_US_dev_base25_mek6_Dmyear25/0000070d6f0af444_20160113_004600_8972/000.tar/frame_0000070d6f0af444_20160113_004911_761791_001718_BA81_e_8333.0_ag_12.0_dg_150_100_180.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}