import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "frame[_]*(?P<fidx>\\d{5,6})[_ .]|(?P<device_id>[0-9a-z]{16})_(?P<date>\\d{8})_(?P<time>\\d{6})_(?P<microseconds>\\d{6})_(?P<frame_index>\\d{6})";
final String string = "/orcam/field_recordings/myear/recordings/2019/06/190611_141138_Unoaa_LOrcam_Cvoice_recording_check_911_up_V9_2_2_ear_en_US_dev_base25_mek6_Dmyear25/0000070d6f0af444_20160113_004600_8972/000.tar/frame_0000070d6f0af444_20160113_004911_761791_001718_BA81_e_8333.0_ag_12.0_dg_150_100_180.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}