# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"frame[_]*(?P<fidx>\d{5,6})[_ .]|(?P<device_id>[0-9a-z]{16})_(?P<date>\d{8})_(?P<time>\d{6})_(?P<microseconds>\d{6})_(?P<frame_index>\d{6})"
test_str = "/orcam/field_recordings/myear/recordings/2019/06/190611_141138_Unoaa_LOrcam_Cvoice_recording_check_911_up_V9_2_2_ear_en_US_dev_base25_mek6_Dmyear25/0000070d6f0af444_20160113_004600_8972/000.tar/frame_0000070d6f0af444_20160113_004911_761791_001718_BA81_e_8333.0_ag_12.0_dg_150_100_180.jpg"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.