package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"\\]*(?:\\[\s\S][^"\\]*)*"`)
var str = `And then, "this is some sample text with quotes and \"escaped quotes\" inside". Not that we need more, but... "here is \"another\" one". Just in case.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}