// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[^"\\]*(?:\\[\s\S][^"\\]*)*""#).unwrap();
let string = "And then, \"this is some sample text with quotes and \\\"escaped quotes\\\" inside\". Not that we need more, but... \"here is \\\"another\\\" one\". Just in case.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}