re = /"[^"\\]*(?:\\[\s\S][^"\\]*)*"/m
str = 'And then, "this is some sample text with quotes and \\"escaped quotes\\" inside". Not that we need more, but... "here is \\"another\\" one". Just in case.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end