package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?:\\+u[a-fA-F0-9]{4})+`)
var str = `Naja, gegen dich ist sie ein Waisenknabe \\ud83d\\ude02\\ud83d\\ude02\\ud83d\\ude02`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}