$re = '/\s*(?:\\\\+u[a-fA-F0-9]{4})+/m';
$str = 'Naja, gegen dich ist sie ein Waisenknabe \\\\ud83d\\\\ude02\\\\ud83d\\\\ude02\\\\ud83d\\\\ude02';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;